Помогите написать программу си++ вот условие задачи: задан массив целых чисел....

0 голосов
51 просмотров

Помогите написать программу си++ вот условие задачи: задан массив целых чисел. Отсортировать четные элементы массива по возрастанию, а нечетные по убыванию. Очень срочно нужно


Информатика (155 баллов) | 51 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Dev-C++ 5.11

#include
using namespace std;

int main(void)
 {const int n=6;
 int arr[n],c;
 for(int i=0;i  cin>>arr[i];
 for(int i=0;i  for(int j=i+1;j   if(arr[i]>arr[j] && arr[i]%2==0 && arr[j]%2==0)
    {c=arr[i];
    arr[i]=arr[j];
    arr[j]=c;}
 for(int i=0;i  for(int j=i+1;j   if(arr[i]    {c=arr[i];
    arr[i]=arr[j];
    arr[j]=c;}
 cout<<"Array"<<endl;<br> for(int i=0;i  cout<<arr[i]<<" ";<br> return 0;}

Пример ввода:
2 6 4 1 5 3
Пример вывода:
Array
2 4 6 5 3 1

(38.6k баллов)