Написать программу, которая выводит ответ "Верно", если число в диапазоне от 100 до 150, кроме 120, и "Неверно" в других случаях
Program chisloq; uses crt; var q: real; begin writeln ('Введите число'); readln (q); if (q <150) and (q>100) and ((q>120) or (q <120)) then<br>writeln ('ВЕРНО') else writeln('НЕВЕРНО'); end.
а почему не просто q <> 120 ?
ну мы в шк, покрайней мере, решали задания наподобие этого, тем способом, как я написала
Правда? Школа это конечно "выдающееся" заведение. Но вообще в программировании культивируется оптимальность и читабельность кода. "Неравно" в паскале обозначается "<>", в языках типа С "!=", еще видела в Lua "~="
ух.. всё сложно...