PascalAbc.net написать программу Ввода-Вывода. 1. Разработать программу, которая...

0 голосов
58 просмотров

PascalAbc.net написать программу Ввода-Вывода.

1. Разработать программу, которая предлагает пользователю ввести с клавиатуры значения трех переменных х1, х2, х3 (оператор readln()).
2. Выводит введенные значения в строчку, отводя на каждое число 6 позиций. При этом необходимо вывести имена соответствующих переменных.
3. Присваивает переменным новые значения 42, 7 и 34 соответственно.
4. Выводит новые значения переменных в столбик, отводя для каждого значения 4 позиции. При этом необходимо вывести имена соответствующих переменных.



Информатика (33 баллов) | 58 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
 x1,x2,x3: real;
 begin
 writeln ('vvedi tri cisla');
 readln(x1,x2,x3);
 write ('x1=',x1:6,'x2=',x2:6,'x3=',x3:6);
 x1:=42;
 x2:=7;
 x3:=34;
 writeln;
 writeln ('x1=',x1:4);
  writeln ('x2=',x2:4);
   writeln ('x3=',x3:4);
   end.

(2.5k баллов)