Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 3%...

0 голосов
347 просмотров

Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется в том случае, если сумма покупки больше 500 руб., в 5% — если сумма больше 1000 руб. (Pascal)


Информатика (14 баллов) | 347 просмотров
Дан 1 ответ
0 голосов

program zadacha;
var
a:integer;
b:real;
begin
writeln('введите сумму покупки');
readln(a);
b:=a;
if a>500 then b:=a/1.03;
if a>1000 then b:=a/1.05;
writeln('сумма покупки с учетом скидки равна:',b);
readln;
end.