1) Написать программу,которая вводит таблицу квадратов первых 10 чисел. 2)Найти все...

0 голосов
29 просмотров

1) Написать программу,которая вводит таблицу квадратов первых 10 чисел. 2)Найти все натуральные числа а,b,с, из интервала от 1 до 10 для которых выполняется равенство а^2+b^2=c^2


Информатика (54 баллов) | 29 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
    i, a, b, c: integer;

begin
    for i := 1 to 10 do
        writeln(i, '^2 = ', i * i);
    writeln;
    
    for a := 1 to 10 do
        for b := 1 to 10 do
            for c := 1 to 10 do
                if a * a + b * b = c * c then
                    writeln(a, '^2 + ', b, '^2 = ', c, '^2');
end.

(55.0k баллов)