Написать программу в Паскале через циклы while и repeat. Вычислить сумму бесконечного...

0 голосов
67 просмотров

Написать программу в Паскале через циклы while и repeat.
Вычислить сумму бесконечного ряда с заданной точностью E=0.5e-6,к=0.


image

Информатика (95 баллов) | 67 просмотров
Дан 1 ответ
0 голосов

Сумма этого бесконечного ряда дает значение  е - основание натурального логарифма,   е = 2,718281828459045....

const eps=0.5e-6;
var k: integer;
    ex,s,fak: real;
begin
   ex:=exp(1);
   k:=0;
   s:=1;
   fak:=1;
   repeat
     k:=k+1;
     fak:=fak/k;
     s:=s+fak;
   until ex-s   writeln('сумма = ',s);
   writeln('точное значение:  ',ex);
end.    

с циклом  while - после  fak:=1;   

while ex-s>eps do
begin
  
   здесь те же операторы, что и в repeat

end;



(9.7k баллов)