Помогите плиииз !!! Надо составить программу ** языке Паскаль,под цифрой 13 .тема...

0 голосов
22 просмотров

Помогите плиииз !!! Надо составить программу на языке Паскаль,под цифрой 13 .тема одномерные массивы


image

Информатика (15 баллов) | 22 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const
  na=6;
  nb=3;
  a:array[1..na] of real=(0.1,0.25,0.32,4.2,10.1,6.2);
  b:array[1..nb] of real=(4.5,6.1,7.3);
var
  i,j:integer;
  s:array[1..nb] of real;
  sum:real;
begin
  for i:=1 to nb do begin
    sum:=0;
    for j:=1 to na do sum:=sum+exp(a[j]);
    s[i]:=i*tan(b[i])+sum;
    Writeln('S[',i,']=',s[i])
    end
end.
   
Результаты
S[1]=24910.8484526962
S[2]=24905.8405961803
S[3]=24911.0608049136

(150k баллов)