1. Написать программу, которая вычисляет сумму первых N четных положительных чисел....

0 голосов
70 просмотров

1. Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N – количество чисел) вводятся с клавиатуры. Результаты работы программы записываются в файл Out.txt.
2. Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N – количество чисел) вводятся из файла Input.txt. Результаты работы программы добавляются в файл Out.txt.


Информатика (19 баллов) | 70 просмотров
Дан 1 ответ
0 голосов

  var a,b,sum,i:int64;  begin   assign (input,'input.txt');assign (output,'out.txt');   reset (input);rewrite (output);     readln(a);  b:=2;  i:=1;  repeat  begin  sum:=sum+b;  b:=b+2;  i:=i+1;  end;  until i=a+1;   writeln(sum);    end.

(410 баллов)
0

Если что-то не выходит, пиши!

0

в общем дело в том, что программа должна складывать только четные числа, а если я введу 1, то все равно ответ будет 2, а если я к примеру введу 10 двоек,то результат будет 6, что-то определенно не так с кодом

0

Ок сейчас решу проблему

0

Я немного не понимаю условий, ты ввел N.... сумму всех четных от 1..до N или как? Если так, то вроде все верно...

0

ааа

0

вот

0

это поправка к если ввести 1

0

var a,b,sum,i:int64;
begin
assign (input,'input.txt');assign (output,'out.txt');
reset (input);rewrite (output);
readln(a);
b:=2;
i:=1;
repeat
begin
if b>a then break;
sum:=sum+b;
b:=b+2;
i:=i+1;
end;
until i=a+1;
writeln(sum);
end.

0

Вот теперь все хорошо, но есть одна проблема, я показал учительнице, она сказала, что в выводе данных должны записываться числа, которые подходят под условие.Тоесть не просто ответ в файле out, а еще сами числа, которые суммируются