Написать программу, принимающую ** вход два вектора (a1, a2, a3) и (b1, b2, b3) и...

0 голосов
31 просмотров

Написать программу, принимающую на вход два вектора (a1, a2, a3) и (b1, b2, b3) и вычисляющую объем параллелепипеда, образованного тройкой векторов a, b, [a,b].
На выходе программа должна выдавать два числа: первое - объем параллелепипеда, второе - является ли тройка векторов a, b, [a,b] компланарной.
РЕШИТЬ НА C++


Информатика | 31 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Dev-C++ 5.11

#include
#include
using namespace std;

int main(void)
 {int ax,bx,abx,ay,by,aby,az,bz,abz;
 float v,amod,bmod,abmod;
 cin>>ax>>ay>>az>>bx>>by>>bz;
 abx=ay*bz-by*az;
 aby=az*bx-ax*bz;
 abz=ax*by-ay*bx;
 amod=sqrt(pow(ax,2)+pow(ay,2)+pow(az,2));
 bmod=sqrt(pow(bx,2)+pow(by,2)+pow(bz,2));
 abmod=sqrt(pow(abx,2)+pow(aby,2)+pow(abz,2));
 v=abs(ax*(by*abz-aby*bz)-ay*(bx-abz-abx*bz)+az*(bx*aby-abx*by));
 cout<<"V="<<v<<endl;<br> if(v==0)
  cout<<"YES";<br> else
  cout<<"NO";<br> return 0;}

(38.6k баллов)
0

дай скайп свой, или в вк