Написать программу, которая вводит массив из N целых чисел и выводит ** экран элементы,...

0 голосов
130 просмотров

Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы, кратные числу K. Протестировать программу на следующих исходных данных: а) k=3 Массив: 2 6 -9 4 5 12 -15 б) k=4 Массив: 9 0 8 124 -16 11 19


Информатика (14 баллов) | 130 просмотров
Дан 1 ответ
0 голосов

const

n=10;

var

a:array [1..n] of integer;

i,k:integer;

begin

for i:=1 to n do

begin

write ('A[',i,'] = ');readln(a[i]);

end;

write ('K = ');readln(k);

for i:=1 to n do 

if a[i] mod k = 0 then write (a[i],' ');

writeln;

readln;

end.

(2.8k баллов)