Записать текст программы и указать используемый язык программирования. Дано: в школьной...

0 голосов
17 просмотров

Записать текст программы и указать используемый язык программирования.
Дано: в школьной столовой имеются вкусные пирожки по s рублей. У учащегося имеется n рублей. Какое наибольшее количество пирожков он сможет купить и какую сдачу получит.
Программа получает на вход два целых положительных числа. Первое число s - цена одного пирожка. Второе число n - количество рублей у человека. Оба числа не превосходят 10 в 9 степени.
Программа должна вывести в первой строке количество пирожков, которые может купить учащийся, а во второй строке - полученную сдачу.


Информатика (844 баллов) | 17 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.Net
var
  s,n:integer;
begin
  Read(s,n);
  Writeln(n div s);
  Writeln(n mod s)1
end.

Пример
8 76
9
4

(150k баллов)