Написать программу для Pascal ABC: Программа вводит 2 строки, затем из короткой строки...

0 голосов
39 просмотров

Написать программу для Pascal ABC:
Программа вводит 2 строки, затем из короткой строки вывод на экран символы, код которых больше 70, а из длинной строки – все цифры.


Информатика (23 баллов) | 39 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.NET 3.2 сборка 1318

Var
  s1,s2,c:string;
  i:integer;
begin
write('Type s1:');
readln(s1);
write('Type s2:');
readln(s2);
if length(s1)>length(s2) then
  begin
    for i:=1 to length(s1) do
      if (s1[i]>='0') and (s1[i]<='9') then write(s1[i]);<br>    writeln;
    for i:=1 to length(s2) do
      if ord(s2[i])>70 then write(s2[i]);
  end
else
  begin
    for i:=1 to length(s1) do
      if ord(s1[i])>70 then write(s1[i]);
    writeln;
    for i:=1 to length(s2) do
      if (s2[i]>='0') and (s2[i]<='9') then write(s2[i]);<br>  end;
end.

Пример ввода:
Type s1:Mi Zu
Type s2:MeL10N
Пример вывода:
MiZu
10

(38.6k баллов)