Помогите пожалуйста: написать программу, которая заполняет массив числами, которые в 5...

0 голосов
25 просмотров

Помогите пожалуйста: написать программу, которая заполняет массив числами, которые в 5 раз больше чем предыдущее число


Информатика (15 баллов) | 25 просмотров
0

Заполнение мы всегда начинаем с 1? Или начальное число вводится с клавиатуры.

0

с 1

0

Na paskale?

Дан 1 ответ
0 голосов
Правильный ответ

const n=5;
var a:array [1..n] of integer;
i: integer;
begin
writeln ('Введите a[1]');
read (a[1]);
for i:=2 to n do  a[i]:=a[i-1]*5;
 for i:=1 to n do write(a[i],' ')
end.

Если ввести a[1]=1, то программа выводит: 1 5 25 125 625
(855 баллов)