Нужно написать программу ** pascal abc

0 голосов
20 просмотров

Нужно написать программу на pascal abc


image

Информатика (329 баллов) | 20 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.NET 3.2 сборка 1318

Var  x1,y1,x2,y2,x,y,x3,y3,x4,y4:integer;
begin
read(x1,y1,x2,y2,x,y);
x3:=x1;
y3:=y2;
x4:=x2;
y4:=y1;
if (x=y1) then writeln('W') else
if (xy3) then writeln('NW') else
if (x>=x1) and (x<=x2) and (y>y3) then writeln('N') else
if (x>x2) and (y>y3) then writeln('NE') else
if (x>x2) and (y<=y2) and (y>=y4) then writeln('E') else
if (x>x2) and (yif (x<=x4) and (x>=x1) and (yif (xend.

Пример ввода:
-2 1 4 4 -3 5
Пример вывода:
NW

(38.6k баллов)