Помогите, пожалуйста, написать программу для ABC паскаль. Нужно сделать так, чтобы...

0 голосов
95 просмотров

Помогите, пожалуйста, написать программу для ABC паскаль.
Нужно сделать так, чтобы программа в ответе выдала xoxoxoxoxo, но при этом мы указываем сколько должно быть столбцов, сколько рядов. Должна получиться шахматная доска. 10 класс
Program Ksenia
Var..... и т.д. Пожалуйста!!!! 39 баллов! Больше нет(


Информатика (1.7k баллов) | 95 просмотров
0

Что значит больше рядом? Типо два ряда это: хохохохохо+хохохохохо

0

количество рядов

0

в ответе должна появиться надпись "введите кол-во столбцов", "введите кол-во рядов". Пишем, например, 3 и 5. И о пишет х0х0х /(пробел) 0х0х0/ (пробел)/ х0х0х. И он должен работать, если задаешь разное кол-во столбцов и рядов

0

не пробел, а энтер

0

сейчас катку скатаю, если никто не решит, то решу :D

0

Ну, что? Как дела xD

Дан 1 ответ
0 голосов
Правильный ответ

Var n,m,i,j:integer;
begin
write('n = ');
readln(n);
write('m = ');
readln(m);
for i:=1 to n div 2 do
 begin
 for j:=1 to m div 2 do write('xo');
 if m mod 2 = 1 then write('x');
 writeln;
 for j:=1 to m div 2 do write('ox');
 if m mod 2 = 1 then write('o');
 writeln;
 end;
if n mod 2 = 1 then
 begin
 for j:=1 to m div 2 do write('xo');
 if m mod 2 = 1 then write('x');
 writeln;
 end;
end.

Пример:
n = 3
m = 5
xoxox
oxoxo
xoxox

(194k баллов)
0

Громадное спасибо! Выручили :))