Напишите код программы ** c++ для решения следующей задачи: дана матрица размером m*n....

0 голосов
31 просмотров

Напишите код программы на c++ для решения следующей задачи: дана матрица размером m*n. Вычислите суммы элементов каждого столбца. Определите наибольшее значение этих сумм и номер соответствующего столбца.


Информатика (348 баллов) | 31 просмотров
Дан 1 ответ
0 голосов

#include

using namespace std;


int main()
{
    int m, n;

    // Выделение памяти и ввод матрицы
    cout << "m = ";<br>    cin >> m;
    cout << "n = ";<br>    cin >> n;

    int **matrix = new int*[m];
    for (int i = 0; i < m; ++i)
    {
        matrix[i] = new int[n];
        for (int j = 0; j < n; ++j)
            cin >> matrix[i][j];
    }

    // Вычисление суммы элементов каждого столбца. Определение наибольшего
    // значения этих сумм и номер соответсвующего столбца
    int sum, max_sum = INT_MIN, max_column;
    for (int j = 0; j < n; ++j)
    {
        sum = 0;
        for (int i = 0; i < m; ++i)
            sum += matrix[i][j];
        cout << "Column " << j << " - sum " << sum << endl;<br>        
        if (sum > max_sum)
        {
            max_sum = sum;
            max_column = j;
        }
    }
    cout << "Max sum in column " << max_column << ". Max sum is " << max_sum << "." << endl;<br>
    // Удаление матрицы
    for (int i = 0; i < m; ++i)
        delete[] matrix[i];
    delete[] matrix;
}

(1.7k баллов)