Ребят, помогите написать программу в языке Pascal ABC (решение с помощью if, then, else)

0 голосов
28 просмотров

Ребят, помогите написать программу в языке Pascal ABC (решение с помощью if, then, else)


image

Информатика (57 баллов) | 28 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var a,b,s:integer;
begin
         a:= 17;
         b:= 46;
         s:= a+b;
         if a<>b then
                            begin
                                     a:= s;
                                     b:= s
                             end
                       else
                             begin
                                      a:=0;
                                      b:=0
                             end;
          write('a = ',a,' b = ',b)
end.

(83.5k баллов)
0 голосов

Var
a,b,c:integer;
begin
readln(a,b);
if a=b then
 begin
  a:=0;
  b:=0;
 end
 else
  begin
   c:=a+b;
   a:=c;
   b:=c;
  end;
writeln('A=',a,' B=',b);
end.

(294 баллов)