Надо в Pascal составить программу. Помогите. 1) Задает следующие вопросы и позволяет...

0 голосов
66 просмотров

Надо в Pascal составить программу. Помогите.

1) Задает следующие вопросы и позволяет ввести ответы:
Как тебя зовут?
Введи номер класса в котором ты учишься.
2) Выдает фразу :
Имя, закончишь школу в ...... году. Верно? Да/нет.
3) Позволяет ввести ответ и анализирует его:
Если ответ да, то выводит фразу: " Ай да я! Ай да молодец!"
Если ответ нет, то выводит фразу: " Ой! Неужели ошиблась?!"
Если ответ ни да, ни нет, то выводит фразу: " Хм! Вечный школьник?!"


Информатика (24 баллов) | 66 просмотров
Дан 1 ответ
0 голосов

Begin 
  var N,X: string;  
  var K,Y: integer;
  var M: longint;
  writeln ('Как тебя зовут? ');
  readln(N);
  writeln ('Введи номер класса в котором ты учишься. ');
  readln(K);  Y:=2016+1+11-K;
  writeln (N,' закончишь школу в ',Y,' году. Верно? да/нет. ');
  read(X);
    if X='да'
      then writeln ('Ай да я! Ай да молодец!')
      else
          if X = 'нет'
          then writeln ('Ой! Неужели ошиблась?!')
          else writeln ('Хм! Вечный школьник?!');
end.

(3.9k баллов)