Напишите программу ** Pascal: Вычислить площадь боковой поверхности прямой призмы с...

0 голосов
36 просмотров

Напишите программу на Pascal:

Вычислить площадь боковой поверхности прямой призмы с боковым ребром (а), в основе которой находится квадрат со стороной (в). (Предварительно найти периметр основания).


Информатика (87 баллов) | 36 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program prisma;
var
  a, b, p, s: real;
begin
  write('a=');
  readln(a);
  write('b=');
  readln(b);
  p := 4 * b;
  s := p * a;
  writeln('площадь боковой поверхности: ', s:1:2);
end.

(7.2k баллов)
0

А можно вариант с применением подпрограмы?