Напишите программу ** Pascal. Задан массив B[10]. Заполнить массив случайными...

0 голосов
50 просмотров

Напишите программу на Pascal. Задан массив B[10]. Заполнить массив случайными числами(-10..10). Вывести на экран в строчку через пробел.
Вычислить сумму всех элементов массива и кол-тво чисел кратных двум.


Информатика (15 баллов) | 50 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1338 от 16.11.2016
begin
  var b:=ArrRandom(10,-10,10); b.Println;
  Writeln('Сумма элеменов массива равна ',b.Sum);
  Writeln('Количество четных чисел равно ',b.Count(x->x.IsEven))
end.

Пример
1 10 3 -4 -10 -1 -6 0 -4 9
Сумма элеменов массива равна -2
Количество четных чисел равно 6
(150k баллов)