Паскаль: Напишите программу, которая меняет местами значения двух переменных в памяти.

0 голосов
146 просмотров

Паскаль:
Напишите программу, которая меняет местами значения двух переменных в памяти.


Информатика (12 баллов) | 146 просмотров
0

Круто, че

0

Я нубас, решаю как умею, используую что знаю. Я думаю школьники будут все таки благодарны за то, что я не юзаю сложных функций, потому что учительнице они это объяснять будут долго. Я не знал, что в паскале ток можно менять

0

Не знаю есть ли смысл на продвинутом уровне учить паскаль. Я бы питончику отдал приоритет.

0

Тут просто школьники питон не одобряют

Дан 1 ответ
0 голосов

Program llllll;
var a,b,c: integer;
begin
    writeln('Введите a');
    readln(a);
    writeln ('Введите b');
    readln(b);
    c := a;
    a := b;
    b := c;
    writeln('a = ' ,a);
    writeln('b = ', b);
end.
   

(1.5k баллов)