Даю много баллов,тому кто напишет мне программу и составит блок схему. ** зыке Си...

0 голосов
24 просмотров

Даю много баллов,тому кто напишет мне программу и составит блок схему.
На зыке Си напишите программу для определения значения упрощенной функции, полученной в п. 1.1 при различных значениях переменных. Составьте блок-схему алгоритма. Упрощенную функция я прикрепила в фото.


image

Информатика (3.4k баллов) | 24 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Блок-схема - в прилагаемом файле.
Программа:
#include

int main() {
int a,b;
printf(" A B | not A | not B | not A & not B\n");
for (a=0; a<=1; a++)<br> for (b=0; b<=1; b++) {<br>  printf(" %d %d %5d %7d %11d\n", a, b, !a, !b, !a&&!b);
}
return 0;
}

Результат:
 A B | not A | not B | not A & not B
 0 0     1       1           1
 0 1     1       0           0
 1 0     0       1           0
 1 1     0       0           0


image
(194k баллов)
0

Спасибо огромное))