Ниже ** пяти языках программирования записан алгоритм. Получив ** вход натуральное число...

0 голосов
55 просмотров

Ниже на пяти языках программирования записан алгоритм. Получив на вход натуральное число x, этот алгоритм печатает число R. Укажите такое число x, при вводе которого алгоритм печатает двузначное число, сумма цифр которого равна 13. Если таких чисел x несколько, укажите наименьшее
из них.
var

x,d,R: longint;

begin

readln(x);

R := 0;

while x>0 do

begin

d := x mod 10;

R := 10*R + d;

x := x div 10

end;

writeln(R)

end.


Информатика (25 баллов) | 55 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

X = 49. Программа обработает его и выдаст "94". Сумма цифр 4 + 9 = 9 + 4 = 13.

(5.6k баллов)
0

спасибо огромное)