Написать программу которая задумывает число и печатает его наоборот. ( пример: 341 и 143)...

0 голосов
44 просмотров

Написать программу которая задумывает число и печатает его наоборот. ( пример: 341 и 143) в паскаль.


Информатика (214 баллов) | 44 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
var m,p:longint;  
  i:integer;
begin
writeln ('Введите натуральное число не более 999999999');
repeat
readln(m);
until(m>0)and(m<=999999999);<br> p:=0;
while m>0 do  
begin  
   i:=m mod 10;  
   p:=p*10+i;  
   m:=m div 10;
  end; write(p);
readln
end.
(80 баллов)
0 голосов

A: = random(500)
Как перевернуть хз

(180 баллов)