Напишите программу которая вводит натуральные числа a и n и вычисляет a^n без...

0 голосов
463 просмотров

Напишите программу которая вводит натуральные числа a и n и вычисляет a^n без использования операции возведения в степень.


Информатика (15 баллов) | 463 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a, n, i: integer;
  r: longint;
 begin
  r := 1;
  readln(a, n);
  for i := 1 to n do
  r := r * a;
  write(r);
end.

(6.9k баллов)