ЛЁГКАЯ ЗАДАЧА ПО ПАСКАЛЮ! Составьте программу, которая позволяет удалить лишние пробелы в...

0 голосов
63 просмотров

ЛЁГКАЯ ЗАДАЧА ПО ПАСКАЛЮ! Составьте программу, которая позволяет удалить лишние пробелы в строке s, оставив по одному пробелу между словами. Строку s, состоящую из слов, разделённых пробеламі, введите с клавиатуры.


Информатика (774 баллов) | 63 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var s: string;
begin
writeln('Введите строку:');
readln(s);
while pos('  ',s)>0 do delete (s,pos('  ',s),1);
writeln(s);
end.

Пример:
Введите строку:
Строку    s   введите с    клавиатуры.
Строку s введите с клавиатуры.

(194k баллов)