ЛЁГКАЯ ЗАДАЧА ПО ПАСКАЛЮ! Составьте программу, которая позволяет удалить из слова X те...

0 голосов
60 просмотров

ЛЁГКАЯ ЗАДАЧА ПО ПАСКАЛЮ! Составьте программу, которая позволяет удалить из слова X те буквы, которые встречаются в слове Z. Слова X и Z введите с клавиатуры.


Информатика (774 баллов) | 60 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var x,z: string;
i: integer;
begin
x:= 'клавиатура';
z:= 'буква';
for i:=1 to length(z) do
 while pos(z[i],x)>0 do delete (x,pos(z[i],x),1);
writeln(x);
end.

Результат:
литр

(194k баллов)