Составьте программу, которая удаляет лишние пробелы в строке s, оставляя по одному...

0 голосов
137 просмотров

Составьте программу, которая удаляет лишние пробелы в строке s, оставляя по одному пробелу между словами. Строка s, состоящая из слов, разделенных пробелами, вводится с клавиатуры.


Информатика (774 баллов) | 137 просмотров
0

На каком языке?

0

Паскаль АБС

0

Точнее. PascalABC.NET или просто PascalABC. От этого зависит простота решения

0

PascalABC.NET

Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>').ToWords.JoinIntoString;
  s.Println;
end.

Пример
>     А   роза   упала на     лапу    Азора
А роза упала на лапу Азора
(150k баллов)
0 голосов

Uses System;
uses System.Linq;var s: array of string;
a: string;
i, x: integer;begin
readln(a);
s := a.Split();
for i := 0 to s.Length - 1 do
  if (s[i].Length <> 0) then
    write(s[i] + ' ');
end.

(1.8k баллов)
0

Для любой пойдут