Составить программу, которая проверяет, делится ли ** 7 целое число n

0 голосов
49 просмотров

Составить программу, которая проверяет, делится ли на 7 целое число n


Информатика (16 баллов) | 49 просмотров
Дано ответов: 2
0 голосов

C++:


#include

int n;

int main() {
    std::cout << "n=";<br>    std::cin >> n;
    std::cout << ( (div(n, 7).rem == 0) ? "делится" : "не делится" ) << '\n';<br>    return 0;
}

(7.2k баллов)
0 голосов

var
a: integer;

begin
writeln ('vvedi cislo');
read (a);

if (a mod 7)=0 then writeln ('da')
 else
writeln ('net');
end.

(2.5k баллов)