Помогите составить программу в паскале: в компьютер вводятся числа числа от 1 до 9. Нужно...

0 голосов
37 просмотров

Помогите составить программу в паскале:
в компьютер вводятся числа числа от 1 до 9. Нужно посчитать количество чётных и нечётных.


Информатика (80 баллов) | 37 просмотров
0

сколько переменных вводится?

Дан 1 ответ
0 голосов

Program help;
uses Crt;
var a,cot,cpo:integer;
begin
ot:=0;po:=0;cot:=0;cpo:=0
repeat
writeln('Число: ');
readln(a);
if a<0 then begin ot:=ot+a; inc(cot);end else<br>if a>0 then begin po:=po+a; inc(cpo); end else
if a=0 then begin
writeln('Кол-во положительных чисел: ',cpo);
writeln('Кол-во отрицательных чисел: ',cot);
end;
until a=0;
readln;
end

(62 баллов)