Напишите программу которая для заданного числа определит сколько понадобится спичек чтобы...

0 голосов
43 просмотров

Напишите программу которая для заданного числа определит сколько понадобится спичек чтобы выложить все цифры числа
Входные данные
1
239
Результат
2
16


Информатика (620 баллов) | 43 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
var a: array[0..9] of integer:=(6,2,5,5,4,5,6,3,7,6);
    i,s: integer;
    st: string;
begin
   write('число: ');  readln(st);
   s:=0;
   for i:=1 to length(st) do
   s:=s+a[ord(st[i])-48];
   writeln('число спичек = ',s);
end.

  
(9.7k баллов)
0 голосов

См. вложенный файл, программа в нём 

(327 баллов)