Помогите решить. Напишите программу формирования массива размером 5х5 с помощью датчика...

0 голосов
51 просмотров

Помогите решить. Напишите программу формирования массива размером 5х5 с помощью датчика случайных чисел замените в нем значения элементов с четной суммой индексов на значение второго элемента массива из первой строки. Выведите на экран исходный и измененный массив. (Паскаль абс) С объяснением


Информатика (234 баллов) | 51 просмотров
0

Можно уточнить,чтобы не возникло неточностей в решении, что такое четная сумма индексов?

0

Сам не понимаю

0

Это может быть i+j? То есть сложить индекс по вертикали и горизонтали?

0

Возможно

0

Это когда (i+j) mod 2 =0

Дан 1 ответ
0 голосов

Const
n=5;
var
a:array[1..n,1..n] of integer;
i,j:integer;

begin
//генератор случайных чисел. Диапазон от 1 до 10.
 for i:=1 to n do
  begin
  for j:=1 to n do
   begin
    a[i,j]:=random(10)+1;
    write(a[i,j]," ");
   end;
   writeln();
  end;

//Проверка условия и переприсвоение, если верно.
 for i:=1 to n do
  for j:=1 to n do
   begin
    if (((i+j) mod 2)=0) then
     a[i,j]:=a[1,2];
   end; 
 
//Вывод полученного массива.
  for i:=1 to n do
  begin
  for j:=1 to n do
   begin
    write(a[i,j]," ");
   end;
   writeln();
  end;

//Ожидание.
readln();
end.

(195 баллов)