Возвести целое число n в nнную степень. Напишите программу

0 голосов
51 просмотров

Возвести целое число n в nнную степень. Напишите программу


Информатика (31 баллов) | 51 просмотров
Дан 1 ответ
0 голосов

Var xn,x,n,i:integer;
begin
write('Введите число ');
readln(xn);
write('Введите степень числа ');
readln(n);
x:=xn;
for  i:=1 to n-1 do
begin
x:=x*xn;
end;
writeln(x);
end.

(1.2k баллов)