Составьте программу, которая проверяет, является ли человек заданного возраста школьником, если возраст школьника - от 6 до 17 лет, и выводит на экран соответствующее сообщение: "Является" либо "Не является".
щас напишу на паскале.
жду...
Сeme4ko, if (a>6) and (a<17) перепроверь, от 6 до 17 включительно!
if (a>=6) and (a<=17) и if (a>5)and(a<18) разницы нет вы меня задрали уже 3 года прошло, а я помню что учитель нам это объяснял
Program check_shk1; uses crt; var a:integer; BEGIN writeln('Введите возраст.'); readln(a); if (a>6) and (a<17) then<br>writeln('Является.') else writeln('Не является.'); END.
почти
if (a>6) and (a<17) перепроверь, от 6 до 17 включительно!
точно, спасибо!
измени "if (a>6) and (a<17) then" на "if (a>=6) and (a<=17) then"
Var a :integer; begin write ('введите количество лет '); readln(a); if (a>5)and(a<18) then write('является ') else write('не является ');<br>end.
Не совсем правильно, если будет введено 5,5 или 17,9 , то программа определит возраст как верный, хотя это не так.
ооо! тебе сомаму такие здачки делать надо, а не за помощью и открой книгу и прочитай что если стоит integer ввести дробь невозможно!!!
у тебя хотя бы паскаль есть на компе? так проверь