Помогите написать программу ** Paskal. Дано целое число X и натуральное N. Составьте...

0 голосов
51 просмотров

Помогите написать программу на Paskal. Дано целое число X и натуральное N. Составьте алгоритм вычисления X в n степени.


Информатика (20 баллов) | 51 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program llllll;
var
x, n: real;
begin
    readln(x);
    readln(n);
    x := exp(ln(x) * n);
    writeln(x);
end.

(1.5k баллов)