Очень нужна помощь!!!!!!!Составить программу, которая проверяет делится ли введенное...

0 голосов
55 просмотров

Очень нужна помощь!!!!!!!Составить программу, которая проверяет делится ли введенное число на 3 и выводит на экран "Делится" или " Не делится"( оператор while)


Информатика | 55 просмотров
Дан 1 ответ
0 голосов

Написали бы на каком языке программирования Вам нужно. Вот на java ^_^
import java.io.BufferedReader;
import java.io.InputStreamReader;

public class prog {
 public static void main(String[] args) throws Exception{
 BufferedReader reader = new BufferedReader(new  InputStreamReader(System.in));
 while(true) {
 int a = Integer.parseInt(reader.readLine());
 if(a%3==0){
 System.out.println("Делится");
 }
 else{
 System.out.println("Не делится");
   }
  }
 }
}

(104 баллов)
0

Pascal ABC

0

var a:integer;
begin
while true do
begin
readln(a);
if a mod 3=0 then
begin
writeln('Делится');
end
else
begin
writeln('Не делится');
end;
end;
end.