Помогите написать программу Если в массиве (из n чисел) есть хотя бы одна тройка соседних...

0 голосов
70 просмотров

Помогите написать программу Если в массиве (из n чисел) есть хотя бы одна тройка соседних чисел, в которой средний элемент больше своих "соседей", т. е. предшествующего и последующего, то напечатать все элементы, предшествующие элементам последней из таких троек.


Информатика (125 баллов) | 70 просмотров
0

числа вводятся с клавиатуры, или можно формировать рандомом?

Дан 1 ответ
0 голосов

Type mas=Array [1...100] of integer;
var i,n,itre:integer;
a:mas;
begin
readln(n);
for i:=1 to n
do read(A[i]);
for i:=2 to n-1
do if (A[i]>A[i-1]) and (A[i]>A[i+1])
then itre:=i;
for i:=1 to itre-2
do writeln(A[i]);
end.

(1.2k баллов)
0

Спасибо большое. Тут написано решение от начала и до конца?

0

да, полностью, только элементы вводятся с клавиатуры, если все так, то бери, но лучше посмотри и под себя погони.

0

спасибо