Используя язык программирования Паскаль выполнить задание: 1. Составить программу для...

0 голосов
47 просмотров

Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.


Информатика (12 баллов) | 47 просмотров
Дан 1 ответ
0 голосов

Var x, y, a :real;
begin
writeln('введите переменные: x, y и a');
readln(x, y, a);
Y:=38*x+231;
M=7*x+6*y+276;
N=sqr(4*a)+2*x*a+8*y;
writeln(x, y и a соответственно равны: ' x, y, a');
end.

упс... не заметил, что нужно в 3 разные программы...

1)
var x, y :real;
begin
writeln('введите переменную x');
readln(x);
Y:=38*x+231;
writeln('y равен: ', y);
end.

2)
var x, y, m :real;
begin
writeln('введите переменную x и y');
readln(x,y);
M:=7*x+6*y+276;
writeln('m равен: ', m);
end.

3)
var x, y, a, n :real;
begin
writeln('введите переменные x, y, a');
readln(x, y, a);
N=sqr(4*a)+2*x*a+8*y;
writeln('N равен: ', n);
end.

(222 баллов)
0

Чувак,спасибо,я тебя люблю всем сердцем)0