Написать программу, которая вычисляет среднюю (за неделю) температуру воздуха. Исходные...

0 голосов
1.5k просмотров

Написать программу, которая вычисляет среднюю (за неделю) температуру воздуха. Исходные данные должны вводиться во время работы программы. Рекомендуемый вид экрана во время работы программы приведен ниже (данные, введенные пользователем, выделены полужирным шрифтом).
Введите температуру воздуха за неделю.
Понедельник -> 12
Вторник -> 10 '
Среда -> 16
Четверг -> 18
Пятница -> 17
Суббота -> 16
Воскресенье -> 14
Средняя температура за неделю: 14.71 град.


Информатика (196 баллов) | 1.5k просмотров
Дан 1 ответ
0 голосов

Var
  a: array[1..7] of string = ('Понедельник', 'Вторник', 'Среда', 'Четверг', 'Пятница', 'Суббота', 'Воскресенье');
  av: real; i, t: integer;

begin
  writeln('Введите температуру воздуха за неделю.');
  for i := 1 to 7 do
  begin
    write(a[i], ' -> '); readln(t); av := av + t;
  end;
  av := av / 7;
  writeln('Средняя температура за неделю: ', av:0:2, ' град.');
  readln;
end.

(386 баллов)