Помогите пожалуйста, информатика, надо написать программу), говорят легко, но я не...

0 голосов
34 просмотров

Помогите пожалуйста, информатика, надо написать программу), говорят легко, но я не разбираюсь


image

Информатика (36 баллов) | 34 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Программа на паскале:
var x,y:real;
begin
write('x = ');
readln(x);
if x>=1
 then y:=x*x+sin(x)
 else if x>0 then y:=(1-x)/sqrt(sin(x)/cos(x))
             else y:=x*x*x+8*x-1;
writeln('y = ',y);
end.

Пример:
x = 3.945
y = 14.8432991568405

(194k баллов)
0

а если там 00) and (x<1)? просто x>0 правильно? да?)

0

Можно и написать, но второе условие (x<1) будет лишним (так как условие x>=1 в этой части ложно).