Срочно нужно написать программу ** Паскале. Переменные x и k

0 голосов
25 просмотров

Срочно нужно написать программу на Паскале. Переменные x и k


image

Информатика (1.9k баллов) | 25 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Вводится последовательность чисел которая заканчивается нулем. Посчитать сколько в ней чисел больше 1

var
    x, k: real;

begin
    repeat
        write('x = ');
        readln(x);
        if x > 1 then k := k + 1;
    until x = 0;
    writeln(k);
end.

Пример вывода
x = 2
x = 1
x = 0
1




(55.0k баллов)
0

2 и 4 больше 1

0

еще вопросы будут?

0

2 в данном случае это K?

0

да

0

k это счетчик

0

То есть последнее значение в программе выдает K?

0

ну да, больше в программе никаких значений и не выдает

0

writeln(k);

0

Огромное спасибо за помощь!

0

для спасибо есть кнопочка)