Составьте программу, Которая формирует массив из десяти случайных целых чисел от 100 до...

0 голосов
49 просмотров

Составьте программу, Которая формирует массив из десяти случайных целых чисел от 100 до 150 и увеличивает в два раза числа, кратные 5, а остальные уменьшает в 2 раза


Информатика (19 баллов) | 49 просмотров
Дан 1 ответ
0 голосов

#include
using namespace std;

int main() {
const int SIZE = 10;
int a[SIZE];
size_t i;
for(i = 0; i < SIZE; i++) {
a[i] = rand() % 51 + 100;
cout << "a[" << i << "] = " << a[i] << '\n';<br>if (a[i] % 5 == 0)
a[i] = 2* a[i];
else
a[i] = (int) a[i]/2;
}
cout << "-----" << '\n';<br>for(i = 0; i < SIZE; i++) {
cout << "a[" << i << "] = " << a[i] << '\n';<br>}
return 0;
}

(7.2k баллов)