Написать программу, которая вводит массив из 8 целых чисел и выводит ** экран элементы с...

0 голосов
104 просмотров

Написать программу, которая вводит массив из 8 целых чисел и выводит на экран элементы с четными номерами


Информатика (96 баллов) | 104 просмотров
Дан 1 ответ
0 голосов

Program zadacha1;
uses crt;
const N=5;  //размер массива
var m:array[1..n] of integer;
i:integer;
Begin
Writeln('Исходный массив');
For i:= 1 to n do
//readln(m[i]); //для ручного ввода оставьте эту строку
begin //    для
m[i]:=random(101)-50; // случайного
Writeln(m[i]); //  эти
end; //
Writeln('Прямой вывод');
For i:=1 to n do
writeln(m[i]);
Writeln('Обратный вывод');
For i:=1 to n do
writeln(m[n+1-i]);
End.

 

Program zadacha2;
uses crt;
const N=5; // размер массива
var m:array[1..n] of integer;
i:integer;
Begin
Writeln('Исходный массив');
For i:= 1 to n do
//readln(m[i]); //для ручного ввода оставьте эту строку
begin //    для
m[i]:=random(101)-50; // случайного
Writeln(m[i]); //  эти
end; //
Writeln('Вывод');
For i:=1 to n do
if i mod 2 = 0 then writeln(m[i]);
End.

 

Program zadacha3;
uses crt;
const N=5; // размер массива
var m:array[1..n] of integer;
i:integer;
Begin
Writeln('Исходный массив');
For i:= 1 to n do
//readln(m[i]); //для ручного ввода оставьте эту строку
begin //    для
m[i]:=random(101)-50; // случайного
Writeln(m[i]); //  эти
end; //
Writeln('Вывод');
For i:=1 to n do
if (n+1-i) mod 2 <> 0 then writeln(m[n+1-i]);
End.

(48 баллов)
0

не правильно