Помогите,как составить программу которая формирует массив из 16 случайных чисел от -20 до...

0 голосов
23 просмотров

Помогите,как составить программу которая формирует массив из 16 случайных чисел от -20 до 20 и определяет если в этом массиве хотя бы одно число кратное трём


Информатика (149 баллов) | 23 просмотров
Дан 1 ответ
0 голосов

Var a:array[1..16]of integer;
i,k:integer;
begin
for i:=1 to 16 do begin a[i]:=random(41)-20; write(a[i],' '); end;
for i:=1 to 16 do if (a[i] mod 3=0) and (a[i]<>0) then begin writeln('est'); k:=1; break; end;
if k<>1 then writeln('net');
end.

(96 баллов)