Цикл "Для". Написать программу 1)Найти сумму квадратов целых чисел от 1 до 100.

0 голосов
24 просмотров

Цикл "Для". Написать программу
1)Найти сумму квадратов целых чисел от 1 до 100.


Информатика (2.1k баллов) | 24 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
  i, sum: longint;
 begin
  for i := 1 to 100 do sum := sum + sqr(i);
  write(sum);
end.

(6.9k баллов)
0 голосов

Var
s,i,n:integer;

begin
i:=100;
s:=0;
For n := 1 to i do
begin
s:=s+i*i;
i:=i-1;
end;
writeln('Сумма квадратов целых чисел от 1 до 100 равна ',s);
end.

(457 баллов)