Составьте программу в паскале которая имитирует движения дельфина или кораблика по...

0 голосов
130 просмотров

Составьте программу в паскале которая имитирует движения дельфина или кораблика по волнам. Или что-то в этом роде.


Информатика (332 баллов) | 130 просмотров
0

а движение велосипеда подойдёт просто я её уже писал

0

да подойдёт

0

так напишете?

Дан 1 ответ
0 голосов
program corablik; uses Graph, Crt; var   grDriver: integer;   grMode: integer;   ErrCode: integer;   x,y,y0,a,b: integer;{a,b-переменные для линии моря, чтоб они не зависели от х,у}  procedure more(a,b:integer); begin moveto(0,y0); setcolor(blue); for a:=0 to 680 do{слева направо рисуем синусоиду синего чвета}   begin   b:=y0-round(sin(a*pi/180)*30);{30-коэффициент масштабирования по оси Х, чем больше, тем волна круче}   lineto(a,b);  end; end;  begin   grDriver := Detect;   InitGraph(grDriver, grMode, '..\BGI');   ErrCode := GraphResult;   y0 := 250;   if ErrCode = grOk then   begin     x:=600;     while x>=0 do{лучше использовать цикл while, можно менять величину шага, что тоже влияет на скорость и частоту смены картинки}      begin       cleardevice;       more(a,b);{рисуем волну}       setcolor(white);{устанавливаем цвет кораблика}       y:=y0-40-round(sin(x*pi/180)*30);{движемся по волне}       MoveTo(x - 40, y + 20);       LineTo(x - 20, y + 40);       LineTo(x + 20, y + 40);       LineTo(x + 40, y + 20);       LineTo(x - 40, y + 20);       MoveTo(x + 15, y + 20);       LineTo(x + 15, y - 40);       LineTo(x - 20, y + 20);       LineTo(x + 15, y + 20);       delay(100); {нормальная скорость, если модули *.TPL не глючные как у Вас,  время должно быть в миллисекундах, а не в каких-нибудь наносекундах}       x:=x-2;{шаг движения}     end;   end   else Writeln('Graphics error: ', GraphErrorMsg(ErrCode));  Settextstyle(0,0,3);{устанавливаем стиль шрифта}  cleardevice;  setcolor(red);  OuttextXY(200,240,'Rejs zavershen!');{выводим надпись}  readln;  CloseGraph; end.
(26 баллов)
0

мог ошибиться исправьте если есть ошибки

0

Detect на что можно заменить, а то программа выдаёт ошибку

0

что за ошибка? скрин если можно

0

Ошибка неизвестный индикатор Detect

0

скрин не прикрепляется