1. Служебное слово Var в программе ** языке Паскаль фиксирует начало раздела программы,...

0 голосов
126 просмотров

1. Служебное слово Var в программе на языке Паскаль фиксирует начало раздела программы, содержащего:
а) описание переменных
б) описание меток
в) описание констант
г) описание служебных типов данных
2. Команда присваивания означает, что:
а) вводятся значения переменных, являющихся исходными данными решаемой задачи
б) выводятся результаты решения задачи компьютером пользователю
в) переменная величина получает значение
г) происходит обращение к новой программе
3. Чему будет равно значение переменной x после выполнения команды x:=x+7, если до выполнения оно было равно 8?
а) 1
б) 2
в) 3
г) 15
4. Определите значение переменной а после выполнения фрагмента алгоритма:
а:=247;
b:=(а div 100)*10+9;
a:=(10*b-a) mod 10;
5. Укажите значения переменных x и y после выполнения операторов:
x:=2: y:=5; x:=y; y:=x;
а) 2, 5 б) 2, 2 в) 5, 2 г) 5, 5
6. Что будет выведено на экран после выполнения фрагмента программы:
Begin
a:=5; b:=12;
If (a>4) and (b>14) then k:=2*a+25
Else k:=4*b-2*a;
Writeln (k);
End.
7. Сколько раз выполняется цикл и что будет выдано на печать?
Var i,k:integer;
...
k:=11;
For i:=-10 to -9 do;
k:=i;
Write (k)
а) 1 раз, -10. б) 1 раз, -9. в) 2 раза, -10. г) 2 раза, -9.
8. Что будет выведено на экран в результате выполнения фрагмента программы:
p:=1;
For k:=5 to 1 downto begin
p:=p*k;
End.
Write (k, k-, p, p-) (насчёт того, что там минусы не уверена, просто зрение плохое не позволяет видеть)
9. Тело цикла для вычисления значений функции f(x)=x⁴ с шагом 0.1 будет иметь вид:
а) f:=x*x*x*x; x:=x+1; writeln(f,x)
б) f:=x⁴; x:=x+1; writeln(f,x)
в) f:=x*x*x*x; x:=x+0.1; writeln(f,x)
г) f:=x*x*x*x; x:=x+0.1; writeln(f,x)
10. Напишите программу для нахождения суммы всех натуральных чисел из промежутка [1, m].


Информатика (277 баллов) | 126 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1. - а)
2. - в)
3. - г)
4. - 3
5. - г)
6. - 38
7. - г)
8. - Write (k, k-, p, p-) - это ерунда какая-то p=120
9) - в), г)
10) - 
var m,i,s:integer;
begin
write('m = ');
readln(m);
s:=0;
for i:=1 to m do s:=s+i;
writeln('s = ',s);
end.

Пример:
m = 5
s = 15

(194k баллов)