Напишите программу: ввести с клавиатуры массив из 8 элементов. Найти сумму элементов...

0 голосов
113 просмотров

Напишите программу: ввести с клавиатуры массив из 8 элементов. Найти сумму элементов кратных 6


Информатика (16 баллов) | 113 просмотров
Дан 1 ответ
0 голосов

#include

#define N 8

int A;

void main(void)
{
int      i, Sum =0;
float   check;

for(i = 0, i     printf ("\nВведите элемент номер %d", i);
     scanf("%d", &A);
     check = A/6.0
     if ((int)check == A%6) Sum+=A;
     }
printf ("Сумма элементов, кратных 6 равна %d", Sum);
}

(2.9k баллов)
0

в паскале нужно

0

Да? И что же ты раньше-то молчала?

0

а почему нельзя сразу (0 == A%6) ? просто интересно

0

Можно. Это яркий пример того, что сделать сложно проще, чем добиться того же результата, сделав просто. Я просто давненько не писал. :-(

0

увы проверить программу не могу так как не на чем. А вообще код вроде выглядит верным