Язык программирования Паскаль. Помогите написать программу по задаче (пример №2). Все...

0 голосов
25 просмотров

Язык программирования Паскаль. Помогите написать программу по задаче (пример №2). Все задание во вложениях.


image
image

Информатика (1.1k баллов) | 25 просмотров
Дан 1 ответ
0 голосов

1. function f( x: float ): float;
var i: integer;
begin
for i := 0 to size-1 do
if (fx[ i ] <= x) and (x <= fx[ i+1 ]) then<br>begin
f := (fy[ i+1 ] - fy[ i ]) / (fx[ i+1 ] - fx[ i ]) * (x - fx[ i ] );
break;
end;
end;
...
x := a;
dx := (b-a) / 10;
while (x <= b) do<br>begin
writeln( x, ' => ', f(x) );
x := x + dx;
end;

2. sqrt( pow( x, 4/5 ) + pow( x, (4-x)/5 ) ) + ln( abs(x-0.25) )

(306 баллов)