написать программу вычисления a^n, где a и n целые числа, при условии, что n>0на...

0 голосов
52 просмотров
написать программу вычисления a^n, где a и n целые числа, при условии, что n>0
на паскале!!!

Информатика (87 баллов) | 52 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,n:integer;
begin
read(a,n);
write(power(a,n));
end.

Или вот так:

var a,n,i,r:integer;
begin
read(a,n);
r:=1;
for i:=1 to n do r:=r*a;
write(r);
end.

(8.5k баллов)